Zen Swing Wallet Code -1 Error


I ran into code -1, and it was because sync’ing the block chain took so long I had to risk closing the wallet to move the machine; sadly I paid the price I hoped I wouldn’t which appears to be mean corrupted block chain file (and that explanation seems to match the actions I took). The wallet app couldn’t handle a close while sync’ing apparently.

So I’m on OSX for crypto (10.13) but not a Mac power user let’s say and looked for /Users/[username]/Library/Application Support/ and there is no Zen folder. If I go to Macintosh HD>Library>Application Support there are folders, but not anything to do with Zen either.

I have a file in a folder that I set up as my Zen backup directory, and it’s 106kb of file that OSX nor Windows (when put on a USB drive and transferred, just to look at) will show me an extension for (ugh, I’m feeling stupid now). It could be that this is the file and it ended up with the extension removed somehow.
Opening with a text editor show binary gibberish. So I’m not sure if this is my file or not, a search for wallet.dat across the whole machine doesn’t pull anything, which is weird because I backup everything I can in the crypto space and very likely followed backup directions carefully months ago when I set this up, but I set up so much crypto I can’t remember the process.

I have my private key and public address, but don’t want to take any action without more guidance… input from the group? Thank you for any thoughts…

Edit: Found the wallet.dat file (combo Apple’s retardation and an id10t error)… proceeding with fix contained in other posts, stand by (LOL).


So was this problem solved… via re-indexing?


It is fixed, and it appears re-indexing was the solution, yes. Thank you.