ZEN 2.0.18 is available now, mandatory update!

ZEN 2.0.18 will be available soon. This is a mandatory update for all exchanges, mining pools, node operators, and full node wallet users. The focus of this version is the RPC method ‘getblockfinalityindex’ update

2 Likes

Horizen core software mandatory upgrade is Today. All exchange partners, mining pools, and full node wallet users must upgrade to ZEN 2.0.18 to avoid disruption to Horizen services.