Unable to collect stats without a nodeid on debian

Hello, this is my first experience in setting up a secure node, but I’m working as a sysadmin so I followed this tutorial without any difficulty :

https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/136872139/Installation

But when arriving to part 8 step 8 (running the node with node app.js), I have an error telling me this : Unable to collect stats without a nodeid.

Here is the output :

Retrieving zen rpc config....
2019-09-20 13:52:12 UTC -- STARTING NODETRACKER
CPU Intel(R) Xeon(R) CPU           E5504  @ 2.00GHz count=8 speed=1600
Node.js version: v10.12.0
Tracker app version: 0.4.0
Node type: secure
MemTotal: 16.03GB  MemFree: 1.60GB  MemAvailable: 13.45GB  SwapTotal: 4.61GB  SwapFree: 4.60GB  
2019-09-20 13:52:12 UTC -- Connected to server ts2.eu. Initializing...
2019-09-20 13:52:12 UTC -- Checking t-address...
Node t_address (not for stake)=my_t_address
2019-09-20 13:52:12 UTC -- Checking private z-addresses...
Balance for challenge transactions is 0.0249
Using the following address for challenges
my_stake_address
2019-09-20 13:52:14 UTC -- Waiting to register
2019-09-20 13:58:12 UTC -- Unable to collect stats without a nodeid.
2019-09-20 14:00:33 UTC -- Server response latency average (last 20) 52ms

And if I leave the terminal open it will display this message endlessly. This is a fresh new server, so this is not an old config problem, and when i open nodetracker/config/config.json, the “nodeid” field is set to null. When I ran setup.js, I had no errors and I thought it was good, but I don’t want to run it again, I saw that some people had trouble by running it again.

Thank you in advance for any help :slight_smile:

running the setup again and setting my region to na instead of eu worked

1 Like

Odd one, but I can’t image it has to do with the region setting. Something must have changed during your second attempt to install.

My apologies for not seeing this sooner.
Changing the tracking server regions is the current fix for this issue. The infrastructure team is aware of this and working on it.

Spencer

2 Likes