Send to z_address on secure node problem


#1

I’m trying to set up a secure node and I get to the part where you send the small amount of zencash from your t_address on the node to 2 z_address per this guide:

https://zencash.atlassian.net/wiki/spaces/ZEN/pages/7537004/Part+7+-+Stake+and+Challenge+Balance+using+Arizen

Step 7: zen-cli z_sendmany $(zen-cli listaddresses | jq -r ‘.[1]’) ‘[{“address”: "’$(zen-cli z_getnewaddress)’", “amount”: 0.0249},{“address”: “’$(zen-cli z_getnewaddress)’”, “amount”: 0.0249}]’

When I ran the command it generated 2 z_address but never transferred the zencash even though I got an opid-xxxx…

I decided to run the command again after several hours and it did the same thing (now I have 4 z_addresses on my node)

I then tried just running a sendmany command in the form of:

zen-cli z_sendmany ‘<t_address sending_address>’ ‘[{“address”: “<z_address receiving_address>”, “amount”: 0.0249}]’

again I get an opid-xxxx… but nothing ever happens.

zen-cli z_gettotalbalance show a balance in my t_address with the result below
{
“transparent”: “0.0499”,
“private”: “0.00”,
“total”: “0.0499”
}

My node is completely synced with the blockchain. What is going wrong? Is there another way to get the funds to the z_address? Another question I have is there any problem with having 4 z_addresses on the node vs 2 like the guide says?


#2

Never mind, I ended up using zencash swing wallet to move the funds over to the z_addresses.