Mining rig 6 GPU..HELP!


#1

Hello everyone. I am on my quest to start mining and I have run into some much needed help! I will post my hardware below. The problem I am running into is that I am not getting my 6 GPU’s to work…windows only sees 4 out of 6 and the 4 it does see, only 2 of them are working. In the bios I can see that all 6 pci ports are highlighted so I know the ports are working fine and the cards are also working because I previously used an MSI SLI plus board and all 6 were seen but I could not get that board to work also. I have been through the ringer on this…hours of searching through forums and I am still getting no where.

Specs:
-6 Gigabyte GTX 1070 windforce graphics cards
-celeron processor socket 1151
-SSD 64gig
-Corsair HX1200I PSU
-MSI Z270 A Pro
-16 gigs DDR4 memory

Current BIOS settings: I have 4g decoding enabled with latency set to 96

Troubleshooting already done:
-Installed windows with UEFI/GPT
-Installed cards 1 by 1
-Installed 1 card then all 5 after
-Flashed new bios
-Swapped 1200W PSU for another 1200W PSU
-Reinstalled windows before and after enabling 4g encoding
-Changed peg0 to AUTO/Gen1/Gen2/Gen3
-Changed latency from 32 to 64 to 96
-Swapped MSI z270 SLI Plus motherboard to MSI z270A pro

I am about to throw this thing out the window and just buy a rig…any help would greatly be appreciated!! Thank you!!


#2

Hey man we’ve all been through this. the first and most important step is always be cool and don’t get frustrated. It took me two days to get windows to recognize all the cards. I eventually decided that SMOS was they way to go and I stick to linux now.

Now lets get back to trouble shooting.

  • Double check all of your connections. Occasionally its a faulty set up. Ensure all your cards and risers are adequately plugged in and powered.
  • Make sure you are running the latest motherboard BIOS
  • Now lets do a reset and start from the beginning. Turn off 4g encoding. Enable onboard graphics to default (PEG - > IDG). connect your monitor to your motherboard.
  • ‘PEG0’ and ‘PEG1’ values to ‘Gen1’
  • Uninstall the Nvidia drivers. Power off. Connect only 1 GPU. Boot up. Reinstall Nvidia drivers.
  • Power off. Connect 2nd GPU. Boot up. Verify windows recognizes all cards (wait a few minutes)
  • Power off. Connect 3rd GPU. Boot up. Verify windows recognizes all cards
  • Power off. Connect 4th GPU. Boot up. Verify windows recognizes all cards
  • Power off. Connect 5th GPU. Enable 4g encoding. Boot up. Verify windows recognizes all cards
  • If error try: latency timer to 96
  • If error try: ‘PEG0’ and ‘PEG1’ values to ‘Gen2’
  • Power off. Connect 6th GPU. Boot up. Verify windows recognizes all cards
  • If error try: ‘PEG0’ and ‘PEG1’ values to ‘Gen1’ or try disabling 4g encoding.

I doubt this is related but 16gb ram is overkill, if its 2x 8gb sticks. pop one of those bad boys in ur main pc.


#3

Thank you very much for your feedback! I unfortunately cannot continue this until I head into the office tomorrow. I appreciate the tips and I will definitely follow your directions. However, I do not have peg1 in my settings, I only have peg 0?? And do you know of any drivers that would be ideal with the windforce cards? I am afraid I might have installed a older 1 possibly? Also, do I keep using the onboard graphics while I connect all the other gpu’s? Thanks Persona!!


#4

No problem at all, I actually have the identical setup. 6x gigabyte G1 1070’s and an MSI Z270-A Pro motherboard. So I assure you its possible.

You should be installing the GeForce® GTX 1070 G1 Gaming 8G rev 1.0 or GeForce® GTX 1070 G1 Gaming 8G rev 2.0 drivers depending if you have rev 1.0 or rev 2.0 cards. double check the gpu boxes if you are unsure.

And no problem about older drivers. Just uninstall, reboot, then install the good ones. After a lot of troubleshooting I believe my issue was actually a drivers issue.

Another thing to note. When you were able to boot up into windows with 4 cards, but only 2 were detected. Did the other two show up as generic VGA device? or were they completely missing from your device manager. Also make sure all your cards light up and fans spin. It’s always difficult to detect if its a bad riser, so lets hope its not that.

If you’re still stuck after a second round of trouble shooting, i’ll flip my rig back over to windows and see what settings I used, and hopefully you’ll be able to copy them 100%.


#5

oh wow the same setup? Hahaha what are the odds?! Thanks again brother! I do keep using the onboard graphics the whole time right?

One thing to note is the cards do not light up…but fans do spin. Hopefully this isn’t an issue :frowning:


#6

thats likely a drivers issue. When you boot up with only 1 gpu connected try downloading a miner and seeing its hashrate. A very thorough setup would involve benchmarking each card individually so you have an idea of how they perform relative to each other. This is helpful when fine tuning the overclocking. Sometimes you have cards that simply underperform, and occasionally you have a rockstar than can take a huge overclock and remain cool and stable.


#7

perfect! I hate to sound like a pest persona but my original question still remains, do I continue to use the onboard graphics after I install the first card and windows sees it? At what point do I stop using it? Or I am assuming I always use it, since we want all the gpu power to mine and not allocated resources to provide output to a monitor? (i am probably sure you will say my assumption is correct lol). Thanks again! Can’t wait to troubleshoot this bad boy!


#8

You’ll always want to use onboard graphics so your display output always connect to your motherboard. That said, the vast majority of miners set everything up and leave their rigs headless (no monitors hooked up).


#9

Persona you are the best. I will troubleshoot on Thursday…have to be in the field today and tomorrow :confused:. I will let you know what happens, I have all day to do it! Thanks again!


#10

Hey Persona. I’m working on this now (snow day, jobs got postponed lol). So right now the system sees 2/3 cards…the third card is showing up in device manager but it has the triangle symbol on it and says error code #43 (windows has stopped this device because it has reported problems). I will try to increase the latency passed 32 and see if this works and try the other steps you posted. We shall see what happens.


#11

Okay Persona. I am stuck now. Only 2/3 cards are showing up. I have changed latency to 96 along with switching peg0 to gen 2 and it still does not work, same error code is being shown. When I enable 4g encoding, I get a black screen and cannot get to windows. I do not know what to do from here :confused:


#12

You’ll only use 4g when you have more than 4 GPUs. So if you have 3 connected, it should be disabled.

If you are seeing 2 out of 3 cards and the 3rd has an error code but its detected, it may be a faulty riser. Try the exact same set up but swapping out the 3rd card to a different card and different riser.

Try latency at the default, i believe its 32. Also your cards should be connected 1 at a time using the image below, you should add them going from 1 to 6.

Try changing to GEN 1.


#13

Hey Persona, 3 cards now work, but when I install a 4th using latency as 32 or 64 with 4g disabled, I get some crazy code on a black screen, which says the following: B1InitializeLibrary failed 0xc00000bb. When I do enable 4g and try every other peg0 options, I just get a black screen…can I smash this thing with a hammer now? lol


#14

That crazy error looks a driver issue, may need to disconnect them all and reinstall latest driver? And the black screen may be because it’s loading video to the 4th GPU added…but my settings in BIOS indicate the on-board gpu is set as the default… :thinking: I am thinking at this point I might have to uninstall and install latest driver? I will wait for you response and see what you think. Thanks for everything persona.


#15

before reinstalling the drivers. try enabling 4g encoding with the 4th card plugged in. After you’ve tried that. then maybe reinstall the drivers.

If that is still an issue, change PCIe support to “Auto”


#16

I now get the black screen after it loads past the bios. I can try and buy a HDMI to VGA converter and see if the output is going to my video card. I don’t get the driver error message now. Any further suggestions?


#17

What were all your settings when you got the 3 cards to work? Can you list them out?


#18

4g disabled
peg0 auto
latency 32


#19

leave 4g disabled,
try peg0 to gen1
latency to 96 or 128

Also make sure your NVidia drivers are installed and working. That is sometimes an issue that conflicts with 4g encoding. so could be an issue on card 5,6.


#20

okay, give me a few mins