Can’t connect to server


#1

I run the ZENCash Wallet on PC. It won’t start properly but I get this error:
“A general unexpected critical error has occured:
error: couldn’t connect to server: EOF reached (code 1)
(make sure server is running and you are connecting to the correct RPC port)
See the console/logfile output for more detailed error information!”

I found the log file but cannot interpret it.

What to do?


#2

Hi @clasanka,

please, look at our Troubleshooting page and let me know if it helps or not.

Have a great day!:sunglasses:

Kind regards,
Kamila
Community Project Manager of ZenCash


#3

Hello,

Yes, it did help at that time.

A few days I got the same issue again. I have now done a rescan and a reindex (took two days!) but the problem did not go away. Same error message.


#4

If even re-indexing does not solve the problem, the zend logs may be examined to look for the problem. zend that is automatically started by the wallet, stores its logs at locations:

Linux:    ~/.zen/debug.log, 
Windows:  %APPDATA%/Zen/debug.log
macOS:   ~/Library/Application Support/Zen/debug.log

This document also explains how to find the log: https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/136872081/debug.log+-+Full+Client+Swing+Wallet+-+Troubleshoot


#5

I don’t see the debug.log file in the directory.Zen%20dir


#6

If the debug log is not created, maybe there is a general problem that zend.exe does not start at all. Is the debug log still missing after you start zend from a command line with:

zend --reindex

?

Before doing anything to fix this, it is a good idea to backup the wallet.dat if not already done:
https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/136872053/ZENCashWallet+Swing+Wallet+-+Backup+Upgrade+and+Troubleshooting


#7

Hello,
I have now rerun the re-indexing and have a log file (attached). The re-indexing concluded with this text :

"- Warning: This version will be deprecated at block height 392512, and will automatically shut down. You should upgrade to the latest version of Zen. To disable deprecation for this version, set -disabledeprecation=2.0.14.

  • Error: This version has been deprecated as of block height 392512. You should upgrade to the latest version of Zen. To disable deprecation for this version, set -disabledeprecation=2.0.14.

[‘zcash-cli.exe stop’ to exit] [Set ‘showmetrics=0’ to hide]"


#8

I forget the file. But how do I attach that? The upload function only allows picture files (jpg, png etc.)


#9

Obviously you are using an older version of the wallet that needs to be upgraded to the latest - https://github.com/ZencashOfficial/zencash-swing-wallet-ui/releases/tag/0.84.0